Your IP address is: 54.198.52.8

Haversine Forums -> AirTrack - General Issues and Support

throttle locks on aircraft when using autopilot

Posted on January 20, 2014 19:14 by scmiles

Have x-plane 10.25 64bit, flight stick is Saitek Cyborg 3D Gold USB.

If I configure the MFD for an ILS approach, SRC:NAV1, A/T/ARM, SPEED, VOR LOC, APP, VNAV

The throttle becomes stuck in the game and will not use the joystick throttle and can only be controlled by AirTrack or the actual throttle lever for the aircraft, even after disabling auto-pilot.

In fact, If I do not completely exit out of X-Plane, the throttle will not work via joystick on any aircraft.

Outside of Airtrack, throttle on joystick works properly.

Any Ideas?

Posted on January 20, 2014 19:18 by skyfox

Hi,

This sounds more like a plane bug. Which plane are you flying? Have you tried with another plane?

AirTrack does not touch the throttle setting at all; in terms of auto-pilot the only thing it does is to engage the modes and set IAS as speed for example. It is then up to the plane to comply, or not.

So this woulds like something related to the plane.

hope you can find what's causing it,
joao @ airtrack

Posted on January 20, 2014 20:26 by scmiles

Tried with Default planes, Cessna, and Cirrus Jet. It happens on both, and only if I use Airtrack, so Airtrack is contributing to the issue somewhere.

Even tried another app, X-mapper Pro and it works fine when using that.

Posted on January 20, 2014 20:52 by skyfox

Can you see the throttle axis of the joystick if you go to Settings -> Joystick & Equipment in X-Plane? And does it move the throttle axis? What about the other axis, do they move?

There is a bug in X-Plane which I reported last year but still seems to be there, in that it sometimes doesn't detect my joystick (a Hottas Cougar) so I have to restart X-Plane over and over again until it does. Depending on which plane and plugins I have loaded, this sometimes can happen very quickly and some other times it takes forever to pick up the joystick.

Not sure if it is related, but just to note that the USB code of X-Plane is buggy and sometimes the fact that you have this or that software installed makes it take more time to process that software and hence miss the USB timeouts or something similar and miss the joystick. It could be something like this in which case AirTrack is just one software which is running and may be causing the timeouts to be missed.

Have you tried with a different joystick and with X-Plane in 32 bits mode? What does your Log.txt file say?

Other than this I don't know what it could be. AirTrack does not touch joystick code or throttle at all. It acts on roll, yaw and pitch when you have RC mode enabled (make sure you have it disabled in AirTrack) but nothing to do with the throttle.

You can also try the old AirTrack plugin version 3.5 instead to see if it makes any difference...
http://haversine.com//files/AirTrackXPL-3.5.zip

Hope this helps,
joao

Posted on January 20, 2014 21:20 by scmiles

All joystick axis show up and function properly in the settings menu.

Have not tried another joystick, this is the only one I have unfortunately. I will try the 32bit exe to see if I get the same result.

Posted on January 20, 2014 21:46 by scmiles

I couldn't get airTrack to work in 32bit mode. However, I did narrow it down to the specific issue is that it does not disengage the auto-throttle button of the aircraft, even if you disengage the CMD in AT the auto-throttle button is still active and the FD is still auto in the aircraft, as soon as I turn off the auto-throttle in the aircraft as well as AirTrack, then throttle control is restored.

Posted on January 20, 2014 22:01 by skyfox

Glad you found it :)

For 32 bits you would need the 32 bit version of the plugin installed for AirTrack.

fun flights,
joao

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd