Your IP address is: 54.158.214.111

Haversine Forums -> AirFMC - General Issues and Support

AirFMC & UFMC, slows down x-plane

Posted on November 26, 2014 18:52 by stenu

Hello,

I noticed that using AirFMC with UFMC takes a lot of time from X-Plane. The FPS meter goes from my modest 20fps to less than 10 and also stops rendering completely for each other second (1 second halted, 1 second running). This starts the very moment I start up AirFMC and connect to X-Plane with UFMC running. This makes AirFMC feel very sluggish. The FPS returns back to normal after shutting down AirFMC and waiting for a while.

This might be a problem how UFMC handles the communication, too, maybe this could be sorted with UFMC author?
I hope this gets solved, the AirFMC is a really cool app!

-J

Posted on December 1, 2014 20:55 by skyfox

Hi,

Sorry for the delay and sorry about the troubles. This is strange, I've never seen the plugin having any impact on frame rates. It is a very light plugin which hardly consumes any resources, so it should definitely not happen.

Could you let me know which version of UFMC, X-Plane and and HSAIrXPL plugin you have installed? Also in which plane? Or if you can, send me your Log.txt file via the support page at http://haversine.com/support so I can have a look.

Could also be a conflict with the x737fmc plugin if you have it installed, make sure you disable it while running UFMC. Someone else had issues with these two recently so just thought it could be that.

hope this helps and that you find the cause,
joao @ haversine

Posted on December 2, 2014 13:58 by stenu

Hi Joao,

I doubt that your plugin is directly causing it. But it communicates with UFMC, and all communication between plugins (assuming you are using the standard plugin messaging) is synchronous, so x-plane has to wait. UFMC might be the slow one responsing, but since I don't know at all how it is implemented internally, everything is just a wild guess. :)

Anyway, I have UFMC 2.8 and the latest HSAirXPL, Win7x64 on an 27" mid2011 iMac, running on bootcamp.

-J

Posted on December 2, 2014 20:13 by skyfox

Hi again,

Strange. The plugin only reads datarefs which are memory locations so this shouldn't stall or decrease the frame rate, and writes to them when you press a key. So unless you press an FMC key, it should not write and hence not give a chance for UFMC to stall in replying or delaying anything.

Does the frame rate increase if you go to Plugins -> Plugin Admin -> Enable/Disable and disable HSAIRXPL ?

Not sure if it is the same, but I have UFMC 2.81 from MAY14 here and making 65fps (without scenery) on a Mac Book Pro with AirFMC running. So it shouldn't delay things unless there is a conflict of some kind.

Try disabling the plugin and seeing if the problem persists. I presume your 2.8 is the same as mine 2.81 but if not I can ask Javier about it.

let me know,
joao

Posted on December 2, 2014 20:15 by skyfox

Forgot to say, the HSAIr-Plugin source code is now open source :)

Have a look at http://haversine.com/forums/2/thread/196 or download http://haversine.com/files/HSAirXPL-4.2.5-src.tar.gz

Been meaning to put it in the downloads page but haven't had the chance yet.

joao

Posted on December 3, 2014 11:44 by stenu

I think the problem is gone. I reinstalled UFMC and now it worked fine. I think I had an older 2.8 version installed but I'm not sure. Anyway, it seems to work now.

BTW, good idea releasing the plugin source code! Have to take a look.

Thanks,
J.

Posted on December 3, 2014 22:17 by stenu

No, I was too hasty, still a problem there. Was flying Dash8-Q400 with UFMC, tried AirFMC in the middle of the flight and problem was back. Shut down AirFMC on iPad, then disabled HSAir plugin, and all was good. Disabling the plugin is not required, normal operation returns after the connection with AirFMC timeouts. Bummer... :/

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd