Your IP address is: 54.198.247.44

Haversine Forums -> AirFMC - General Issues and Support

Airfmc and iPad 1

Posted on November 22, 2015 20:09 by Tinamus

Hi, i've installed Airfmc app on iPad 1...it's working fine, but it doesn't rotate whenever i rotate tre iPad...on iPad 2 it's working fine. Is it possibile to fix tris but on the next release?
Thx a lot.
Bye.

Posted on November 23, 2015 20:14 by skyfox

Hi,

Do you mean rotate the navigation display the compass? It should rotate even with the iPad 1.

But you need to:

1) On the settings page make sure HDG is set to COMPASS and not to COURSE

2) On the EFIS/ND page make sure you are in APP or VOR mode. The default MAP mode is based on COURSE so it only rotates with the GPS course.

hope this helps,
joao @ haversine

Posted on November 23, 2015 20:36 by Tinamus

No i mean airfmc app. ..
I can't rotate The app on ipad 1 when i rotate my ipad It'works only in one vertical direction

Posted on November 23, 2015 20:52 by skyfox

Ah, I'm so sorry, my fault, my brain automatically switched to AirTrack and compass and I didn't read properly :(

Indeed you are totally right... AirFMC only works in Portrait mode but on the iPad 1 for some reason it only works in one of the portrait modes not upside down. I just confirmed this with an iPad 1 here.

This is probably because AirFMC uses newer iOS SDK orientation detection schemes which were not available in iOS 5. Unfortunately the iPad 1 only runs iOS 5.1.1 whereas all other iPads can run the latest iOS and hence have it fixed.

I'll make a note and try to fix but I fear it might not be possible anymore; the latest X-Code from Apple which is the tool/SDK with which the apps are developed doesn't support iOS 5 anymore in its current version and when I plug the iPad 1 it says that it cannot be used for development, so it will be difficult to test even if it were made to support the old orientation scheme in iOS5 :(

sorry about it :(
joao @ haversine

Posted on October 25, 2016 05:32 by Jasseji

Hello, perhaps sorry for necropost but will the AirFMC and AirTrack still work with an iPad 1 ?
How about 1st Gen iPad Mini just for AirFMC ?

I have one lying around somewhere - i was using AirTrack a while ago and now wanted to try AirFMC but since then i broke my iPad Air :D

Posted on October 25, 2016 09:20 by skyfox

Both AirTrack and AirFMC currently require iOS 8.0 or higher which make them both incompatible with the original iPad1 which only runs up to iOS 5.1.1

If however you've bought either a while ago you may still be able to install an older version on the iPad 1 from the app store. Not the latest version but an older version.

The iPad mini AFAIK can run iOS 8 so you should be fine with it and run the latest version.

fun flights,
joao @ haversine

Posted on October 25, 2016 09:30 by Jasseji

Ok, thank you, i shall then try to get AirTrack to run on the old iPad1 - for AirFMC i am considering getting an iPad Mini anyway (as the "full" iPad seems to big for a CDU)

Posted on July 15, 2017 10:52 by cristianjays

Hi, and for a long time I use your software purchased on my ipad, and a first-generation ipad with 5.1 upgradeable system, now that I use the ixieg 737 I can not download the new update because my ipad's software is not Supported, it is possible to have a version compatible with io 5.1, we are many to have this problem, not to incur much money to buy a new ipad just to use your software thanks!

Posted on July 18, 2017 07:33 by skyfox

Hello, really sorry, unfortunately for as much as we'd like to, the current Apple development tools (Xcode) don't allow building for iOS 5 anymore, which is why the iPad 1 is no longer supported :(

As the IXEG support came after these changes occurred in Apple's Xcode, we weren't able to produce a working version for iOS 5. Would really like to but it seems to be no longer possible :(

sorry about it,
joao @ haversine

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd