Your IP address is: 54.158.214.111

Haversine Forums -> AirTrack - FS9 / FSX Plugin

Problems getting FSX to connect

Posted on October 14, 2013 21:41 by aslsw

I've just downloaded and installed Airtrack on my iPad. I also downloaded the FSK plugin and ran it, getting the warning messages in FSX about the new gauge. I also got a warning from the Firewall and selected to allow the program to communicate through the firewall.

I do get the white box in the top left hand corner of my cockpit (ie. 2D) screen but for some reason the plugin won't connect to the iPad and send data to it.

I'm running Windows 8 on my laptop. I admit I'm no expert but I have created a firewall rule to allow UDP2442 through in both directions (I think).

What else can I try? Any suggestions? I'm happy to tinker around a bit.

[EDIT] I even (briefly) turned the firewall off and on again but no luck.

[EDIT2] Is there some way that I can delete the whole thing and start again?

Posted on October 15, 2013 09:12 by skyfox

Hi,

The UDP port is 2424 and not 2442. In general it is to do with connectivity so you're right in trying to disable your firewall or anti-virus to see if it works.

But it can also be to do with non standard network setups, or with routers not supporting multicast, amongst other things.

So the best way is to try a manual config and see if it works:

1) Note down the IP address of the iPad from its WiFi settings
2) Create a text file with notepad called "airtrack.ini" in the main FSX folder and write the IP address there
3) Launch FSX and switch to 2D cockpit view
4) You should now see "FSX on X.X.XX" under data sources in AirTrack. Don't forget to tap on it to connect.

hope this helps,
if not let me know and we'll look further,
joao @ airtrack

Posted on October 15, 2013 12:59 by aslsw

Good catch, I spent so long on my laptop last night I might have got the port number wrong in my post or in the firewall settings or even both. I've never changed firewall settings in Windows 8 before, but I'll check the number.

I'll try your suggested steps steps.

The problem with my network is that I am living in a rented apartment with Internet access continuing under the owner's arrangements ie. I'm not sure if I will have access to dig into router settings.

By the way, does the gauge show up as a 'program' so that I can deliberately allow it to have access through the firewall ie. as a named program rather than just a port number.

Posted on October 16, 2013 21:04 by aslsw

I did both - changed the port setting in the firewall and created the "airtrack.ini" file and the app now works. I did a test flight and really enjoyed the screen but I think I need to go through the manual now.

I did some more testing, and renamed the "airtrack.ini" file and the iPad kept working after I restarted FSX. I then tried to fire up the app on the iPhone and it couldn't find a data source so I amended the "airtrack.ini" file to show the iPhone's IP address and it work.

Now I have deleted the "airtrack.ini" file and both iPad and iPhone work. Am I correct in saying that the "airtrack.ini" file is only needed to fetch the FSX navigation data, but after that it is not needed? Because I just did a flight without a "airtrack.ini" file and both iPad and iPhone are working and interacting as expected with FSX ie. if I change an AP setting in one, it updates across the others and on my laptop screen,

Posted on October 17, 2013 09:09 by skyfox

Under normal circumstances AirTrack should work without the airtrack.ini file. It should all be automatic and you should have it running on both iPad and iPhone.

If there is a problem with the network connectivity negotiation then you may use the airtrack.ini as a replacement. By the way, you can add both the iPad and iPhone's IP address, one per line, if you want to run both.

But from what you describe the app works after you used airtrack.ini once. Possibly it won't work again after you reboot.

My guess, but this is just a guess, is that by using airtrack.ini you are forcing packets out to the iPad and iPhone's IP address specifically so your firewall gets open automatically for those ports and their return packets. When you then remove airtrack.ini the firewall state is still there and packets still flow.

By not using airtrack.ini your computer will send packets to a multicast IP address on port 2424 and will receive replies from the unique address of the iPad or iPhone. Because it then doesn't know these it doesn't let them in.

So if possible try creating a firewall rule with something like:

permit UDP IN and OUT from port 2424
permit UDP IN and OUT to port 2424

Or permit anything from/to the IP addresses of the iPad/iPhone, etc ...

So you should be able to make it working automatically by tweaking the firewall I think. But if not, and it may be another problem like ARP requests being missed, etc, you can always use the airtrack.ini solution.

hope it goes well,
let me know if you have any problems,
joao @ airtrack

Posted on October 17, 2013 10:57 by aslsw

Thanks for the detailed response.

I will try again tonight (if my wife will allow me!) and see if it continues to work from a cold start on the laptop.

I have used the Windows8 tool to make changes to the firewall to allow everything in and out but if they aren't working then it looks like I will need to do some reading. Also need to check how/if multicast is working on this router.

Posted on October 18, 2013 14:01 by aslsw

OK, I tested it again and the firewall settings don't seem to have made any difference so it's back to leaving the "airtrack.ini" file in place.

Although the router is just using DHCP to deliver IP addresses, they don't seem to ever change for my iPad and iPhone ie. the IP addresses remain the same.

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd