Your IP address is: 54.158.214.111

Haversine Forums -> AirTrack - FS9 / FSX Plugin

Fsx plugin

Posted on December 22, 2014 23:25 by Rhammondjr

We have tried 2 different fsx simulators with no luck! (Same wifi). Both inbound and outbound udp port 2424 are setup. The PC 194.168.1.90, the iPad 192.168.1,91 and the wifi 192.168.1.1 are all in the same net. The airtrack icon shows up but times out and disappears. I believe we have a wifi issue? We also tried script airtrack.ini with no joy. When I get home I will try to ping wifi to insure its in the network. Seems like this should have been much easier, but we must be missing something. This is fsx with acceleration.

Any thoughts

Thanks

Rick

Posted on December 28, 2014 12:09 by skyfox

Sorry for the delay :(

If the AirTrack icon appears for 1 minute when you switch to 2D cockpit view this is a good sign. It indicates that the plugin is launching successfully and things should run. The icon disappears after 1 minute but this is normal and expected, the plugin however continues to run.

So it sounds like a WiFi / connectivity issue. There must be a firewall somewhere or anti-virus blocking traffic to port 2424 of AirTrack (iPad). Check also your router's configuration or try with an ad-hoc network instead to see if that fixes it.

By default the plugin runs in multicast mode (no configuration needed) but some routers don't support it. In this case put the IP address of the iPad in the airtrack.ini file in the main FSX folder and restart FSX which leads to unicast communication.

hopefully one of these will work,

in any case, if you see the icon for 1 minute then the plugin is running and it is a firewall/connectivity issue.

If you have the chance of running a sniffer on your network you may try and see if traffic is flowing correctly or being blocked.

joao @ haversine

Posted on September 18, 2015 12:23 by danisman

Same problem here ..

o Working FSX, icon visible before timing out in 2D cockpit, port 2424 open in and outbound on Microsoft Firewall, PC connected & tested with WiFi adapter and also Ethernet (both connecting to Virgin SuperHub v1 (NetGear hardware) over 2.4GHz WiFi and powerline Ethernet adapters

o Internet works for browsing and all other apps but not iOS app. Multicast enabled in Virgin router firewall settings but this seems to be only for 'internet' (not 'intranet' which this problem is related to, i.e. 192.168.0.1-255 subnet).

o Cannot connect from iPad with iOS7.1.2, iPad Mini with iOS8.4.1 sometimes sees FSX, sometimes doesn't, very frustrating!

o Other vendor apps such as iFMS and PositionGames FSXfollow-type apps all work fine.

o The .ini file created and populated with iOS device IP addresses. Thinking that is what helped iOS 8 device sometimes work. Any ideas?

Question 1: red circle on AirTrack gauge means what? On or Off?
Question 2: is there another way to check traffic flow? Is the gauge using SimConnect? Is there an FSUPIC version? How do we test traffic .. do I need WireShark?
Question 3: AirTrack .ini file goes where? 'C:\Users\"username"\Documents\Flight Simulator X Files' or 'C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X' ?
Question 4: does the open app on iOS device constantly check the server IP .. ie. will app dynamically update 'Flight Data' sources in 'Settings' page? Only shows 'Device Location Services' at the moment.

Thanks

Posted on September 23, 2015 08:42 by skyfox

Hi,

Terribly sorry for the delay.

1) Red circle means OFF; you want the black/yellow icon.

2) You can use WireShark to monitor traffic to UDP port 2424

3) The second, i.e. C:\Program Files....Simulator X

4) Yes; the plugin constantly sends UDP packets to port 2424; initially they are sent using Multicast so your router needs to support this or you need to configure it manually using airtrack.ini

When the app receives such a packet it creates a data source from it and subsequent packets are interpreted.

---

Not sure what could be causing it, but if it is intermittent, i.e. sometimes AirTrack sees it sometimes it doesn't this suggests that packets are being lost; as they are UDP packets they are unreliable. Try checking your WiFi network or perhaps changing WiFi channel?

Also I presume your Internet interface is your computer is the same as your Intranet / iPad / iPhone interface right? If not you may need to add either the airtrack.ini file with the IP addresses of iPads and iPhones, or to add a static route for the multicast address.

hope this helps,
sorry about the troubles,
joao @ haversine

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd