Your IP address is: 54.198.247.44

Haversine Forums -> AirTrack - FS9 / FSX Plugin

AirTrack PlugIn with P3Dv3

Posted on November 28, 2015 16:49 by morkunas

It seems the format of MiniPanel.cfg in P3Dv3 has changed. Is there an update to enable the AirTrack plug-in for for version 3?

This is my current minipanel.cfg file

; These are all the possible sections we look for
; depending on the aircraft type. You dont have to
; have all these sections, we will use the most specific one found
;
; [MiniPanels]
; [MiniPanels SingleEngine]
; [MiniPanels MultiEngine]
; [MiniPanels NoVacuum]
;
; [MiniPanels Prop]
; [MiniPanels Prop SingleEngine]
; [MiniPanels Prop MultiEngine]
;
; [MiniPanels TurboProp]
; [MiniPanels TurboProp SingleEngine]
; [MiniPanels TurboProp MultiEngine]
;
; [MiniPanels Jet]
; [MiniPanels Helicopter]
;
[MiniPanels]
MiniPanel00=Mini Panel Gauges
MiniPanel03=AirTrack

[MiniPanels Jet]
MiniPanel01=Mini Panel Gauges for Single Engine Aircraft

[MiniPanels NoVacuum]
MiniPanel02=Mini Panel Gauges for Primitive Aircraft

[MiniPanel00]
position=7
size_mm=600,100
window_size=0.9,0.20
child_3d=1
background_color=0,0,0
ident=MINIPANEL

gauge00=MiniPanel!Airspeed, 0, 0, 100, 100
gauge01=MiniPanel!Turn Coordinator, 100, 0, 100, 100
gauge02=MiniPanel!Attitude, 200, 0, 100, 100
gauge03=MiniPanel!Heading Indicator, 300, 0, 100, 100
gauge04=MiniPanel!Altimeter, 400, 0, 100, 100
gauge05=MiniPanel!Vertical Speed, 500, 0, 100, 100

[MiniPanel01]
position=7
size_mm=500,100
window_size=0.75,0.20
child_3d=1
background_color=0,0,0
ident=MINIPANEL

gauge00=MiniPanel!Airspeed, 0, 0, 100, 100
gauge01=MiniPanel!Attitude, 100, 0, 100, 100
gauge02=MiniPanel!Heading Indicator, 200, 0, 100, 100
gauge03=MiniPanel!Altimeter, 300, 0, 100, 100
gauge04=MiniPanel!Vertical Speed, 400, 0, 100, 100

[MiniPanel02]
position=7
size_mm=400,100
window_size=0.6,0.20
child_3d=1
background_color=0,0,0
ident=MINIPANEL

gauge00=MiniPanel!Airspeed, 0, 0, 100, 100
gauge01=MiniPanel!Compass, 100, 0, 100, 100
gauge02=MiniPanel!Altimeter, 200, 0, 100, 100
gauge03=MiniPanel!Vertical Speed, 300, 0, 100, 100

[MiniPanel03]
size_mm=25, 25
window_pos=0.01, 0.01
background_color=0,0,0
ident=10099
visible=1
update_rate=10
gauge00=airtrackFSX!AirTrack, 0, 0

Posted on December 2, 2015 19:31 by skyfox

Hi,

I am not exactly sure how it should be configured in v3 at present as haven't tried it yet, but I've heard from a user that has made it work with P3D v3 so yes, it will run, but may be a matter of tweaking the config files until you figure it out.

I assume the above doesn't work?

Posted on December 2, 2015 21:10 by morkunas

No joy. I tried tweaking it to match the schema but I am just shooting in the dark. If someone has a working configuration for v3 please post it up.

Andrew

Posted on December 3, 2015 08:41 by skyfox

Do you have a missionspannel.cfg file? Apparently this is the file that should be changed in P3D V3, not mini panel.cfg

Somewhere there should be a set of 11 panels and AirTrack should be added as 12.

Let me know if you can find this file and if you could post its contents ...

thanks,
joao @ haversine

Posted on December 3, 2015 14:43 by morkunas

Tally Ho - You have to follow the instructions for installing with FSX SP2 and it works fine now with P3Dv3.

Thanks,
Andrew

Posted on June 14, 2016 22:28 by ghurley0298

So I'm having the same problem - can't get AirTrack to work in P3Dv3. Andrew, which instructions for installing FSX SP2 are you referring to?

Posted on June 16, 2016 09:47 by skyfox

Just a thought, I noticed when I once installed P3D that I had to run P3D in Administrator mode (rick mouse click for run ...) in order for the plugin to be have rights to bind to the UDP port and hence be executed / started.

If all else fails might be worth the try.

joao @ haversine

Posted on June 17, 2016 11:20 by morkunas

@ghurley0298 -- From the readme file:

If you use FSX SP2 copy the line
Window10=AirTrack
in the file FSX_DIR/Gauges/missionpanels.cfg just after the line:
Window09=Countdown

and the following lines at the end of the file
[Window10]
size_mm=25, 25
window_pos=0.01, 0.01
background_color=0,0,0
ident=10099
visible=1
update_rate=10
gauge00=airtrackFSX!AirTrack, 0, 0

Save the file and start FSX. You´ll be prompted to use an
"unknown" file airtrackFSX.gau to be used and authorize the file
airtrackFSX.gau to execute every time you start FSX. Accept both times.

Remember to increment the [Window##] to the next available number.
http://prntscr.com/bhhs3d

Posted on June 28, 2016 02:07 by ghurley0298

Thanks for the help everyone. Unfortunately I still can't get AirTrack to work on my P3DV3. I have tried everything above, I've tried to make a file with the IP Address of my ipad and put it in the main file. Here's what's odd: when I first open P3DV3 and get into the cockpit the AirTrack icon is in the top left corner. But my ipad (on the same network, I checked!) does not recognize it. Then after about 30 seconds the Airtrack icon disappears from the top left corner.

Anyone have any guesses? Thanks again for all the help!

Posted on July 10, 2016 20:17 by ghurley0298

I also forgot to mention, that Airtrack is running very well when i fly P3DV2, it just does not connect when using P3dV3.

Posted on July 22, 2016 08:27 by skyfox

Hi,

Not sure if this will help, but I remember this happening, not sure if with P3DV3 or FSX.

Try running P3D as administrator; right click on the mouse on top of the icon and select Run as Administrator. This will make sure that the plugin is able to open the necessary UDP ports and hence run.

Just an idea, but hope it helps,
joao @ haversine

Posted on July 22, 2016 08:29 by skyfox

Other than that, check your firewall settings to make sure you allow traffic to UDP port 2424. If you see the icon the plugin has launched, so it must be a network problem.

You can also issue netstat -nab or something similar to make sure that the UDP port 2424 is bound and in listening mode.

joao

Posted on March 19, 2017 16:22 by tjordas

Finally... Τhere is compatibility with p3d v3? There is someone who succeeded?

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd