Your IP address is: 54.198.223.170

Haversine Forums -> AirTrack - Frequently Asked Questions

I'm having problems connecting X-Plane / FS9 / FSX to AirTrack. What can it be?

Posted on April 25, 2011 22:39 by skyfox

This is probably the most common problem and frequently asked question for which there are several possible answers and fixes.

AirTrack and its plugin(s) start-off by "trying to be clever", which is to say, they use a special type of network transmission technology called multicast which allows the plugins and AirTrack to negotiate network parameters without you having to enter IP addresses or ports anywhere. In other words, they try to auto-detect and auto-configure themselves accordingly. This works out of the box in 95% of the cases, but there are always some network topologies in which it doesn't work. Worry not, not all is lost and there is still hope.

A pre-requisite for auto-configuration to work is for both the plugin and your iDevice (iPod, iPad, iPhone) to be on the same IP subnet, another pre-requisite is for your router to properly handle multicast packets, and a third pre-requisite is that the interface that you use to connect your computer to the iDevice is the same that you use to connect to the Internet.

Before going any further, start off by making sure that:

1) You don't have a firewall enabled, or that if you do, your firewall is allowing packets to flow out towards port 2424 and backwards.

2) You don't have an anti-virus blocking the same above traffic. If you do, try disabling it and see if it works.

3) Make sure that your iDevice is connected to the WiFi network by showing the WiFi symbol on the status bar.

---

Assuming tha all these are fine and that you still can't connect, it might mean that auto-configuration is not working for another reason (different subnets, lack of multicast support, etc...)

4) Being so, there is now one way to circumvent the problem; instead of relying on auto-configuration, you can force the plugin to send information to a specific and fixed destination:

a) On your iDevice, go to Settings -> WiFi and select your WiFi network to reveal the IP address of your device; note it down.

b1) When using X-Plane, go to the Plugins -> AirTrack preferences menu and enter the iDevice's IP addresss there.

b2) In FS9 or FSX, create a text file in your FS9/FSX main directory called airtrack.ini and write the IP address of your iDevice in that same text file. Save, and restart FS9 or FSX.

This will instruct the plugins to send traffic to the specified IP address, thus ignoring auto-configuration.

There are two drawbacks of this approach however:

i) If you have DHCP configured in your router and your iDevice keeps getting a different IP address each time, you will need to update the settings or the airtrack.ini file each time. A way to avoid this is to try and configure a static IP address / reservation for your iDevice based on its mac address, something that is possible in most routers.

ii) By not having auto-configuration working you will be limited to one device per flight, i.e. one iPad or iPod or iPhone, as opposed to having an unlimited number of devices connected to the same flight.

So in summary, you should try to get auto-configuration working, but if it doesn't, and if you only want to connect one device, set-up a fixed IP address using one of the methods above. In this case configuring a static lease/reservation/IP address for your iDevice in your router might avoid you having to update its IP address in the plugin everytime it changes.

---

If all these things fail, don't hesitate in contacting us using the support form, and we'll get back to you as soon as possible and try to troubleshoot it and find what's causing the problem.

Note: You need to be logged in to post in the forums.

© 2017 Haversine Ltd