Your IP address is:

Haversine Forums -> AirTrack - General Issues and Support

X-Plane Flight Controls & AirTrack

Posted on April 9, 2014 05:38 by scubaguy

Good morning,

This might be my own "doing", but I'm not aware of how I could check this, so here goes:

I frequently use AirTrack (iPad) to control course and heading on X-Plane 10 (Mac), which so far has worked fine. Yesterday, however, I was about to roll to the runway when I noticed that (with the external view one) yoke controls were causing irrational behavior on the plane (later tried out other planes ... same issue, so not X-Plane based). At some point I reset the aircraft and recalibrated my X-Plane controls, but to no avail. Also, I was idling at an airport when, all of a sudden, the engine revved up to max and my controls wouldn't change it or bring it down again...After I had restarted X-Plane (and even my Mac at one point) I switched off AirTrack and voilĂ , the problem was gone.

By "causing irrational behavior" I mean: I would turn right, the rudders would twitch to the right, then go back to the middle position; the same to the left. The same happened when steering up or down.

Now, again, it's possible I made some changes to the MCP, but I couldn't find anything, especially when I had disabled any Autopilot commands.

Any ideas out there? Could there be some "iPad/Mac" interference that's causing this? Obviously, until I find what caused this I'm hesitant to use AirTrack for fear it'll cause further unwanted behavior.


Posted on April 9, 2014 09:19 by skyfox


My guess would be RC mode. There is a button named RC (for remote control) on the PFD/MFD. This button effectively makes the iPad work like a joystick by moving it in 3 directions controlling roll, yaw and pitch

So if it was in RC mode it could be that the rudder control of AirTrack was imposing on your own rudder.

So make sure you have RC mode off.

hopefully it is this,
fun flights,
joao @ airtrack

Posted on April 9, 2014 11:07 by scubaguy

Thanks for the quick reply Joao! Will check this at home tonight ... could this also be to "blame" for the sudden revving up of the engine?

Will report back when I've had a chance to verify on the setup.

Posted on April 9, 2014 17:21 by skyfox

I think the revving up the engine is unrelated. Don't see why it should happen, there is nothing in AirTrack that I can think could cause it :(

Posted on April 10, 2014 05:59 by scubaguy

You're probably right ... didn't manage to test AirTracks behavior re the yoke last night, but will do tomorrow. However, there's a chance the throttle issue might have come from my re-calibrating the controls (incl. the throttle) in an effort to fix the control issue above.

Will report back as and when I have more information. Thanks!

Posted on April 11, 2014 09:30 by scubaguy

Hi Joao,

On the "inadvertent throttle issue" I've discovered that the A/T Arm seems to have been to blame. While I did not have Autopilot active, I accidentally activated A/T Arm, which revved the engine to full capacity. Even after I had deactivated A/T Arm, the revs did not come down and it took a movement on my throttle to get them back into sync.

Don't know whether this constitutes a bug, but please have a look into this and feed back when you get the chance.

Thank & Rgds!

Posted on April 11, 2014 11:05 by skyfox

Good to know, thanks. Don't know why it would turn the engines to REV though. The A/T button set the corresponding variable in X-Plane for its Auto-Pilot's author-throttle. It is all it does and it used to work well.

But it may be that something changed in X-Plane recently regarding this variable and that it is causing it to behave differently. Could be a bug of X-Plane or could be that the plugin needs to be changed to reflect this new behaviour. I'll have to look.

thanks for bringing it up,

Note: You need to be logged in to post in the forums.

© 2022 Haversine Ltd