Your IP address is:

Haversine Forums -> AirTrack - General Issues and Support

AirTrack crashes when entering flight plan

Posted on October 13, 2015 06:26 by FlyPaper

Hi Joao,
This is still connected with my former post on May 26 2015 with an additional issue. The JarA330 and 320, and now particularly the a320 ANY release, including the latest.
Seems like everytime I enter the flight plan and finalize the arrival airport STAR, the app blinks out. If I restart the app, everything is ok UNTIL i cross the first waypoint and then wham, crash again. I'll restart and same happens on the next waypoint. Furthermore, the the efis map mode on AirTrack on my ipad/iphone will STILL display the PLAN mode while I am in the MAP mode. I have three ipads from 1 to the latest mini as well as three iphones from 3 to 5s all running the allowable latest update. My computer is literally a monster with 36 memory, gtx980ti 6gb, and everything top of the line and only for x-plane. My navigraph is always up to date as is my OS, windows 7 pro 64bit. I run one of three instances/releases of xplane (10:36 to the latest 1040 plus a beta.)
I also have the latest plug-in for AirTrack. I've used the old one on occasion for the 330 so the efis and plan mode coincide. Surprisingly, with the latest plug-in, the a330 despite having the map and plan mode confused, does not crash upon flight planning or crossing waypoints.
This is getting pretty frustrating and hopefully you have a solution up your sleeve :)
Thanks for your help and work.

Posted on October 13, 2015 22:35 by skyfox

Ciao Luigi,

Relating to the PLN versus ARC mode, see:

Just uploaded a new plugin which partially fixes it.

Concerning the crash bug, would it be possible for you to give me a step by step guide of things inserted in the MCDU of the Airbus that cause the crash. Just so I can try and replicate the crash and identify the problem. I can probably fix it in another plugin but need to replicate it.

Just to confirm, you enter the flight plan star in the FMC of the Airbus and it is AirTrack that crashes right? In which screen are you when it crashes?

If you could give me a step by step guide to cause the crash (insert the plan, STAR etc) would be great and I'll take it from there.

Sorry about the troubles,
joao @ haversine

Posted on October 14, 2015 03:37 by FlyPaper

OK, I simply put in a Flight Plan. From and To...then departure SID, and arrival STAR and whatever is needed in between, but normally not. OR, I take a pre-made flight plan and enter and, for each and any way, to the prefs, fuel, etc. When approaching the runway to the beginning of the flight plan, the app crashes. I re-up the app, take off and first way point the app crashes, I re-up again (after removing the app from the screen), continue on my flight and then next way point/TOC/TOD/ the app crashes again. I re-up again (whew'!!) then next way point crash again! So that is what and how it's done.
Thanks again, I'll try that new plug-in for the map/rose/plan mode problem.

Posted on October 14, 2015 05:58 by FlyPaper

Just completed two flights from LPPT-LPFR with 320 and 330 and not only is the ND working good, no crashes at all! Your work is done on this..thanks. Great job!

Posted on October 14, 2015 08:43 by skyfox

Weird, I didn't specifically fix anything related to the crash, but perhaps it was there from a previous update :) glad it works, let me know if it crashes again.

fun flights,

Posted on October 15, 2015 08:38 by FlyPaper

You wont believe this. Today, I fire up xplane, load the 320 and AirTrack (with yesterdays new plug-in still there). The map/plan is still OK...however, I put in the flight plan same as usual, and when I finalize the plan (by doing the arrival STARS after entering the departure SID), the app crashes again. I re-installed the new plugin and same thing happens on restart....sorry to tell ya this news again. But something weird is going on, especially since yesterday it worked 100%!
now what!?!
So I restart the app, all is there. I then enter my altitude and another crash.
edit 2
just sitting on the runway adjusting my flight console, nothing to do with any programs/apps, and the app just crashed. I'll re-up the app again and fly now
edit 3
no probs with the 330...yet! still climbing out, no crash of app. btw, the final part of the a320 flight never crashed, once it got to the tod all went well

Posted on October 15, 2015 20:30 by skyfox


Not surprised it still crashes as hadn't changed anything related to it.

From what you describe it's not something specific but sounds that happens randomly. I can't really replicate it here, it doesn't seem to crash and don't know how to make it crash :(

I'll have a look at the code, I suspect it is the A320/A330 writing something unexpected in a certain position memory and AirTrack/plugin not being able to deal with it. I'll try and find it.


Posted on October 18, 2015 03:21 by FlyPaper

Thanks. If you need some more help, let me know...ciao

Posted on October 19, 2015 14:00 by FlyPaper

Hi joao ...some info for you to go on. If this dont help, I'm a gonna make a video of what I'm doing to get the crash. Now, the 330 is still good. The 320 seems to do well IF I DO NOT put in the arrival STAR. AC follows the plan almost to the 'T', but when I get close to my arrival, I enter the runway and star and almost immediately the application crashes.
Please let me know if you are following this thread still. I've been busy and haven't been able to fly/post much. But I'm hoe now and going to begin a short flight,
Thanks for all your help and work!

Posted on October 19, 2015 17:10 by skyfox

Hi Luigi,

Yes please. If you could make a video and send me by email would be great. I just emailed you with the address.

Many thanks,

Posted on October 20, 2015 09:09 by FlyPaper


Posted on October 21, 2015 19:05 by skyfox

OK so with your invaluable help we found the bug :)) Many thanks!

It turned out that the A320/A330, in order to represent its SID and STARs on X-Plane's flight plan, creates a sequence of latitude/longitude pseudo points. AirTrack currently only supports up to 100 waypoints and its plugin wasn't expecting anything above 100 since the original X-Plane FMC had this as a maximum.

By inserting the SIDs and STARs as a sequence of waypoints the airbus was exceeding 100 points and causing AirTrack to crash.

As a quick fix, a new plugin HSAIRXPL-4.3.3 has been released and is available in the downloads section. This plugin limits the number of points to 100 ignoring the exceeding ones and thus avoiding the crash of AirTrack.

Coming soon, an updated AirTrack with support for more than 100 points and this problem no longer observed. For the time being HSAIRXPL 4.3.3 or above.

fun flights,
joao @ haversine

Posted on December 10, 2015 22:14 by ham73

I need a HELP with a AirTrack crash - I am using AirTrack as standalone without any connection so plugin is not helping...WHEN are you going to post a new version of AirTrack??


Posted on December 14, 2015 19:46 by skyfox


Where exactly does AirTrack crash ? Also, with which device / iOS version / AirTrack version ?

Not sure when there will be a new version of AirTrack as unfortunately without much time these days, but hopefully soon.

However if it crashes for you it must be something different since you're using it standalone, so let me know what is causing it, or write through:

And I'll get back to you by email.

joao @ haversine

Posted on October 16, 2017 14:57 by antun2


DEVICES: iPad Air 2 / iPhone 6
IOS VERSION: 10.3.3 on both devices
AIRTRACK VERSION: 3.9.4 on both devices

Airtrack keeps crashing when opening a stored flightplan on iPad.
Works perfectly on my iPhone 6.

Same app, same IOS, same airtrack version on both devices.
I tried re installing the app on iPad many times, no result.

What is happening here?


Posted on October 16, 2017 15:20 by skyfox

antun2 sound's like a bug ... I can try and replicate / fix it. Could you send me the flight plan by email so I can try and make it crash here?

I'll send you an email,
joao @ haversine

Posted on October 18, 2017 00:12 by antun2

Mail received, thx.
Any updates??

Posted on October 18, 2017 09:43 by skyfox

Just replied, can't seem to replicate it. Could be on of the iPad crashing bugs which I'll try to fix soon in a next release, or could be the flight plan is damaged somehow. Recreated a new one for you, let me know.

Also, not sure, are you using it with X-Plane or standalone?

let me know and sorry for the crashes,

Note: You need to be logged in to post in the forums.

© 2022 Haversine Ltd