Your IP address is:

Haversine Forums -> AirTrack - General Issues and Support

Prepar3D 4.3

Posted on June 29, 2018 06:17 by KymAH

Everything was OK in previous versions of P3D but I cannot get the gauge to connect with Prepar3D 4.3

The gauge is installed into P3D as before but the connection does not show on my iPad.

Would this be needing an update?

Regards Kym

Posted on July 4, 2018 10:30 by skyfox


Sorry for the delay.

So it worked with 4.2 but not 4.3? Hum, it’s the 64 bit gauge then. I have no idea, I’ll have to install and check :(

The P3D plugin is not well maintained as it is based on really old code from a third party developer. Do you know if anything that could cause it changed in 4.3?

sorry for the trouble,
joao @ haversine

Posted on July 4, 2018 23:55 by KymAH

Thanks for your reply.

I don't know what of the many changes could cause the gauge to stop working as I'm not a programmer but rather than paste the changes with 4.3 here, I'll provide the link:-

I don't expect anything to work forever and I have thousands of dollars worth of scenery, aircraft and utilities sold by larger companies that still have not been updated from earlier versions leaving me more than just a little disappointed.

If you are unable to find a solution, I'll still be more than happy with the use I've had over the years with Airtrack so regardless, thanks for a fantastic application.

Regards Kym

Posted on August 30, 2018 04:31 by pilot4g

Same problem here after upgrading to Prepar 3D V4.3
worked fine in 4.2 no problems in that version

I really miss this as one of the very best add on to any flightsim I have used
hope that the developers decide to fix it to work with V4.3

V4.3 has many feature fixes and additions and so reverting back to V4.2 is not desirable.
If anyone finds a solution or fix please keep advised


Posted on August 31, 2018 11:38 by skyfox

Sorry for the delay, haven't had a chance to see if it can be fixed, it might be a while but will try.

joao @ haversine

Posted on October 11, 2018 23:27 by KymAH

Hi Joao,

Just wondering if you hsve an answer on this yet.

If it can't be fixed then we might as well remove it from our iPads.

Regards Kym

Posted on October 12, 2018 09:21 by skyfox

Hi Kym,

Thanks for reminding me,

I'll try to look at it asap and come back to you.

kind regards,
joao @ haversine

Posted on October 13, 2018 04:45 by KymAH

Thanks Joao

Posted on November 9, 2018 15:47 by skyfox

Hello John, Kym,

Very sorry about the tremendous delay in checking this! The truth is I've been without a Windows computer to test this for a long time, without a proper broadband Internet connection and away from the computer for long periods of time as I moved house, and only now just managed to get one with Windows 10 to install everything and test.

So I've finally installed a clean new P3D v4.3 downloaded today ( installed everything and then downloaded the P3D 64 bit plugin from:

I then copied the airtrackFSX.gau to Program Files\Locheed Martin\Prepar3D\gauges kind of directory as per instructions, and edited the mission panels.cfg file

I added both the Window14 line and the Window14 section as per instructions.

Saved it. Had a bit of trouble on this as I wasn't Administrator and the saved file ended up with a .txt extension, so I had to copy it to the desktop, remove the old one, rename it to .cfg and copy it back to the gages directory. You may do it differently.

I then launched P3D and selected a King Air 350 (to make sure it had a Cockpit view)

I switched the main view to Cockpit -> Cockpit

And to my surprise the AirTrack icon appeared on the top left corner of the screen and AirTrack was running fine and capturing the flight data on the iPhone. I was expecting some kind of problem but no :(

So I really don't know what could be wrong in your config if eve it is still wrong. It is very possible that in one of the latest updates Locheed Martin fixed a problem and things are back to normal, so make sure you have the latest version 4.3.29

Or it may be that somehow in the upgrade some files were overwritten and that you need to edit missionpanels.cfg again.

I really don't know but hope you either already managed to make it work or can make it work again following these steps I just took today.

let me know, it has to work!

thanks, and again so sorry for the delay.

hope this helps somehow,
joao @ haversine

Posted on November 9, 2018 21:40 by KymAH

Thanks for your efforts and time Joao.

I am on and have been since the day of it's release.
The icon has been appearing in P3D as before but the app on the iPad has stopped communicating for me since

I will follow your steps and try again ASAP though.

Regards Kym

Posted on November 10, 2018 00:52 by pilot4g

I have tried this install procedure several times and rechecked several times.
I also have viewed the “airtrack icon” on screen but the problem is there is no connection showing in the ipad airtrack app. It just never connects So something must have changed with the Prepar 3D V4.3 version that kills the communication to the App running on the ipad.

Have tested with X-plane work as usual but not Prepar 3D V4.3


Posted on November 10, 2018 01:35 by KymAH

Hi All,
Exactly the same for me as for John.

The icon is there in P3D but no connection showing in the ipad airtrack app.

Xplane 11.30 Beta works fine.

Ports allowed in Nortons and have tested with Firewall and Anti-Virus off.

Regards Kym

Posted on November 10, 2018 13:05 by skyfox


OK then that is good news. If the icon loads that means the plugin loads which means that it has to be a network problem of some kind so UDP packets are not reaching AirTrack on the iPad.

It could be that a windows update at some point changed some firewall or port settings. Or it could be something related to the router and configuration of multicast.

You mention that X-Plane works fine but X-Plane works with a slightly different protocol. Or perhaps different launching permissions? Could you try launching P3D as administrator just to see if that works?

Alternatively, what you can do is to configure a static IP address to which to send data to (i.e. the IP address of the iPad but could be any IP address).

1) With Notepad edit a file and write the IP address there:


2) Save the file as airtrack.ini on the desktop

3) Copy the file to \Program Files\Locheed Martin\Prepar3D folder (the main folder not the gauges)

4) Launch P3D and switch to Cockpit view

At this point the computer / plugin should start sending UDP packets to the IP address you entered in the text file regardless of multicast auto-configuration. The packets are sent from and to UDP port 2424.

If you have access to a packet analyser try and see these packets flowing. For test purposes you can also configure any IP address, doesn't need to the be IP address of the iPad.

Essentially it must be a network problem of some kind and if auto mode doesn't work you can try the above manual configuration mode. I don't think it's related to the plugin or P3D as it's launching as you say, must have been a coincidence or something.

let me know how it goes,
joao @ haversine

Posted on November 11, 2018 01:35 by KymAH

Hi Joao,
Thanks for the solution.

Prepar3d has never run properly for me unless comparability is set to Run as Admin so that wasn't it.

As previously mentioned, Port (UDP port 2424) was allowed in Nortons and I have also tested with Firewall and Anti-Virus off but that didn't help.

Creating the airtrack.ini file with the one liner (my ipad address) made life good again and with the first few minutes of flying, I realized how much I missed the application.

Thanks for the solution as it worked.

While it only appears that John and I had the problem, many people find a problem in forums and don't take part but simply wait to see if the problem gets solved so you should probably mention this possible problem and the solution just in case it helps others.

Thanks again, SERIOUSLY!

Regards Kym

Posted on November 11, 2018 03:00 by pilot4g

Awesome to see that this might be the fix for airtrack also will be great to use it again in prepar 3d v4.3

My question now is can the airtrack.ini file have more than 1 IP address? or support a range of ip addresses?
I have 2 ipads and would be nice to have both ip addresses set up so I can use without having to edit if I change ipads


Posted on November 11, 2018 12:25 by skyfox

Hi John,

Yes, you can add several IP addresses to the text file, one per line.

Unlike with auto-config, the addresses don't need to be on the same network so in theory you could even add a remote IP address and monitor your flight from the other side of the world :)

Note: You need to be logged in to post in the forums.

© 2022 Haversine Ltd