Your IP address is:

Haversine Forums -> AirTrack - General Issues and Support

Suggestion for improvement

Posted on September 30, 2019 11:11 by JoseAlmeida


I know it is not possible at present to pass flight plans directly from x-plane to airtrack and I frequently enter manually the plan I want to follow into the app, however when this is done, airtrack shows my plane on the screen and I can see it following the track but the next waypoint is not updated as I fly.
I would suggest that airtrack could automatically detect the passing of waypoints by way of distance. The passing of a waypoint could be detected by an inversion of the change in distance to this waypoint; is this feasible?
Thank you.
José Almeida

Posted on September 30, 2019 17:32 by skyfox


Yes and it is already like that; when AirTrack is running the flight plan in standalone mode (i.e. its own flight plan which you load separately) it will advance to the next waypoint when you fly over one of them. You will see the lines in the FMC page going green meaning they have been completed or passed.

This is down in terms of distance indeed as you suggest. It could perhaps be improved a bit.

You may need to pass close a waypoint for it to advance.

hope this helps and you can see it working,
Joao @ haversine

Posted on September 30, 2019 17:35 by JoseAlmeida

Hi Joao,

It does not work for me in my Ipad; is there anything I can do?

Note: I know you can write in Portuguese but I will keep to English in public places.

Posted on September 30, 2019 18:08 by JoseAlmeida

Now that I think about it, maybe it's not detecting the waypoints because the plane bypasses them in flight; but this would not explain the cases when the legs are aligned.

Posted on September 30, 2019 18:24 by skyfox


The next waypoint (the line in white) needs to be the one you're flying to, otherwise it won't work. If you passed a waypoint and it didn't update or you missed it, you can activate the next one by scrolling with DOWN/UP and pressing -D>

That line will then turn white as you're flying to it and it should update / freeze the time when you pass it. Otherwise I don't know why it wouldn't work, will have to try again myself as it has been a while.

Posted on September 30, 2019 20:10 by JoseAlmeida

Hi João,

No, it definitely doesn't work. I even rebooted the ipad but it did not help.

Posted on October 1, 2019 12:47 by skyfox

Hum, not sure what's wrong, I just tried it and it worked here:(

Unrelated but just for the record so other people can read later, there are two ways in which AirTrack manages / displays flight plans;

1) Flight plans entered in X-Plane native format which are read by the plugin using the XPLMNavigation SDK calls. This works for default planes that use the this engine but it sometimes doesn't work if a third party plane implements its own flight management system and doesn't expose it to the SDK. This flight plan is sent automatically to AirTrack and is displayed on the FMC. The progress is both dictated by X-Plane's active waypoint so it comes from X-Plane.

2) Standalone / local mode; you create the flight plan in AirTrack or have it loaded from your Air Account; it works on AirTrack only. If you load a flight plan in AirTrack it becomes local by default until you press CLR twice to go back to accepting X-Plane flight plans.

Although unlikely it is possible that of X-Plane messes the local / standalone flight plan so if you want to be sure that you have only the local plan, go to the Settings App of the iPad/iPhone (the one from Apple), scroll down to AirTrack and enable STANDALONE mode for Flight Plans.


Now for the local AirTrack mode and crossing the active waypoint; I just looked at the implementation and it is rather crude. I admit it could be better and I'll add it to the ToDo list to improve; in particular it should use the reverse distance mechanism as you suggested which it isn't using at the moment.

How it works: when you're flying towards the active waypoint it automatically moves to the next one when you become within 2NM of it; this is to allow for both fly-over and fly-by waypoints. So just come within 2 nautical miles of it and the waypoint will progress.


How I tried just now;

Loaded a flight plan from EGLL to LPPT via SAM, KAPEX, BEVEL in AirTrack, ... took off with SAM in yellow, passed SAM within 2NM and it automatically switched to KAPEX. Used X-Plane 11.35 and the default 737NG.

So it could be that it is reading the X-Plane flight plan instead, or that you're not somehow within 2NM of the point?

Either way the detection algorithm is definitely worth improving;

hope this helps somehow,
joao @ haversine

Posted on October 1, 2019 13:07 by JoseAlmeida

There's just one thing I don't understand; you say: " go to the Settings App of the iPad/iPhone (the one from Apple), scroll down to AirTrack and enable STANDALONE mode for Flight Plans." I don't see AirTrack on the settings page.

Posted on October 1, 2019 13:15 by skyfox

The settings app of the iPad, scroll down until you see several Apps, one will be AirTrack. This is different from the settings page of the App. Unfortunately there was no space to fit this info although it should be put in the app itself at some point.

Posted on October 1, 2019 13:31 by JoseAlmeida

Found it, enabled Stand Alone but waypoints are still not detected, even for in-line legs (waypoint is not bypassed).

Note: You need to be logged in to post in the forums.

© 2022 Haversine Ltd