Haversine Forums -> AirFMC - General Issues and Support

Connection problem

Posted on May 17, 2014 08:59 by Tinamus

Ho joao, i purchased yesterday airmfc and installed last version of plugin from org.
When i load plane,t777, airfmc doesn't works, it still remain on waiting for connection.
I suppose i need to open udp port on my router, but i don't know if i have to set ipad IP and udp port or pc-xplane IP and udp port on router's configuration interface.
Is it 59000 the port? It's the port showed on airfm.

Thx a lot bye.

Posted on May 18, 2014 10:04 by haversine


First of all, is the plugin loaded? I.e. can you see HSAIR on the list of plugins in X-Plane?

And does it work with other planes?

There are 3 ways of connecting AirFMC:

1. Auto-mode; if your router supports multicast you should see "X-Plane X.X.X.X" on the SIMS page where X.X.X.X is the IP address of your PC. Click on it to select it.

2. If auto-mode fails you can note down the IP address of your iPad, go to the plugins menu, select settings, and insert Y.Y.Y.Y the IP address of your iPad there. Then go to the SIMS page and you should see X-Plane there.

3. Alternatively note down the IP address of your computer running X-Plane (X.X.X.X) go to the CONNECT page and insert that IP address there. Yes the port is 59000. Press CONNECT to try and connect

In order for any of this to work, if you have a firewall you need to allow UDP packets from flow to and from:

X.X.X.X port 59000 <-> Y.Y.Y.Y port 2425

And for auto mode to work you need to allow the same UDP packets from:

X.X.X.X port 59000 <-> port 2425

hope this helps,
let me know how it goes,
joao @ haversine

Posted on May 18, 2014 18:47 by Tinamus

Solved, it was my fault.
Great app, it'awesome!!!

Posted on July 12, 2014 14:22 by JackMc93

Hey guys hope you're all well

I've just loaded up the Flight Factor 777 and went to use Air FMC, it connects to the sim but nothing appears on the screen on my iPad
The app changes to show the style of the 777 fms but the screen remains blank
I'm using the latest version of the 777 as well as the Airfmc plugin, any help would greatly be appreciated!

I currently can't check to see if this too is affecting the JAR A320 as I'm flying on Vatsim

Take care guys!

Posted on July 13, 2014 16:45 by haversine


Could you confirm, which version of the 777 are you using? The latest I have is 1.6.0 as I didn't get the update for 1.6.1 and there is a chance that that might be it.

But it could also be due to the network; the 777 (as well as the 757 and the CRJ-200) use a different scheme to get the screen data; for these, AirFMC connects to your computer's TCP port 18387 in order to retrieve the screen.

What you describe suggests that the 777 is being detected but the screen gathering is not working. So it may be that you have a firewall or anti-virus or even your router that is blocking incoming connections to port 18387 (TCP). If so, could you try disabling any firewall/antivirus and checking that traffic is not being blocked?

The other planes (including the A320) use a built-in protocol with the plugin so they should work fine.

let me know if the above solves it for you.

thanks and sorry for the troubles,

Posted on July 13, 2014 21:20 by JackMc93

Hey Joao thanks for getting back to me so quickly!

I am indeed using the latest version being 1.6.1 but have noticed that the screen error only occurs with the 300 variant and the 200ER
No problems whatsoever with the LR and Cargo variants both load the data correctly.

I have no firewalls or antivirus software so I know that's not the issue.

Could it possibly have something to do with the fact I'm using the latest beta of X-Plane being 10.30 beta 6? Maybe a bug of sorts?
I'll fire up a stable version of X-Plane 10.25 to see if the issue persists there too

Have a great evening


Posted on July 18, 2014 19:24 by haversine

Hi Jack,

Finally been able to try 1.6.1 and the latest beta 10.30b7 and couldn't find what you described so perhaps it was solved in b7.

But I found that the 777-200ER wasn't being detected so it would default to the X-Plane FMC style.

Which I now corrected with version 4.2.4 of the plugin.

Please pick it up from http://haversine.com/airfmc/downloads

and let me know if the problem persists with beta 7 of X-Plane.

All seems to be working fine here thus far.


Posted on July 18, 2014 20:55 by JackMc93

Thanks for the speedy response Joao

Everything now works as it should, so it does look like there may have been an issue with one or two of the patches during the 10.30 beta run

All aircraft variants now display correctly so thanks for the help and getting the updated plug in out so fast!

Hope you have a great weekend my friend, take care


Posted on November 29, 2014 00:01 by sdhawkeye01

So I've been using the AirFMC for sometime now and its worked just like I would expect it to, however as of the last couple weeks the Airfmc gets to the connect to FMC page and when i hit the button it does nothing. Does not connect to the 777-200. I have your latest plugin version installed and the currant xplane version installed. Any thoughts? I miss having it


Posted on December 1, 2014 20:50 by haversine

Reply here: http://haversine.com/forums/11/thread/262

Posted on January 2, 2018 20:50 by Sc000ter

purchased this today and love the look of it. Can't get it to connect though:
-was able to get updated METAR for cyvr no prolem so I have a wifi connection
-Unable to see HSAIR in the plug in menu. Not loading as far as I can see in the log.txt
What do i do?

Posted on January 3, 2018 13:08 by haversine


If you send a message through support and let me know the contents of your Log.txt file as well as your Resources/plugins folder, I can have a look.

I presume you installed the latest X-Plane plugin available from http://haversine.com/airfmc/downloads ?

It should load of course, and you should see "Haversine Air" in the list of X-Plane plugins.

The METARs work from the Internet directly hence they don't need the plugin.

let me know,
joao @ haversine

Note: You need to be logged in to post in the forums.

© 2023 Haversine