Haversine Forums -> AirEFB - General Issues and Support

Various Problems at first time

Posted on December 27, 2017 17:18 by Tinamus

Hi guys, after i used for last two years airfmc, i decided to add airefb to my sw's collection of xplane, but i've a lot of problems....

1. everytime i select one of the nearest airport that the app show me on the airpott data map page (with gps enabled) the app crash to "deskptop"

2. i don't know how to understand if the app is connected with sim.

3. i loaded zibo 737 and here it's clist.txt file, but i can't see any checklist on the airefb interface.

Charts loaded on cloud works fine.

Thanks for this app i hope i can use as fast as possible because i think it could be the second must have for xplane after airfmc.

Posted on December 27, 2017 20:22 by haversine


1) I’m very sorry, this was the first bug found and only happens on older iPads with iOS 9. I presume you can’t upgrade iOS on that iPad? But don’t worry a, a new updated version 1.0.1 is already at Apple waiting for review. They are closed for Christmas but reopen tomorrow so hopefully the update will be with you very soon.

2) In order to connect or see if you’re connected, go to the Settings Page. X-Plane x.x.x.x should appear in one of the lower keys. Tap on it or it’s LK / RK to connect. You know if it’s connected / selected if the button next to it is Green.

3) I presume you have installed the latest 4.7 plugin and deleted the old one right? This is also needed for 2).

Assuming you have the right plugin and are connected wait a few seconds / minute or two to sync all airports and checklists. Then go to checklists and see if the zibo’s list is there. If not, try powering off the EFB and on again on the top-right button.

If this still fails let me know which version of X-plane are you running so i can test here again. Is it on a Mac or Windows or Linux?

It should work but i’ll try again here. We used the zibo for testing so it’s totally supported. Remember the plugin and make sure it’s 4.7

let me know how it goes, sorry about the bug, it’s the first version and testing that on iOS 9 failed as all our ipads were on 11. i’ll update this thread as soon as 1.0.1 is out

joao @ haversine

Posted on December 27, 2017 21:29 by Tinamus

HI joao don't worry about bugs I'm sure you'll fix very quickly.
Yes I've got iPad 2 with iOS 9 I don't know if I can upgrade but I prefer to wait for your fix.
The other problems I'm sure are caused by missing connection to the sim because I don't see xplane in the page you say.
I've win 7 professional edition the of is on the net by cable and iPad in Wi-Fi.
Yes I downloaded last plugin but tomorrow I'll check again.

Posted on December 27, 2017 21:31 by Tinamus

Airfmc is on the same iPad and it works correctly.
Maybe need I to switch to normal Wi-Fi? Now I'm connected to the 5 ghz Wi-Fi.

Posted on December 27, 2017 22:38 by haversine

Which plugin version do you have? AirFMC may be using a previous version.

Posted on December 29, 2017 11:09 by haversine

Hope you made the checklists work.

Just to let you know, AirEFB 1.0.1 is now available on the app store fixing the crash in iOS 9.

fun flights,
joao @ haversine

Posted on December 29, 2017 19:16 by Tinamus

Thanks for you service joao.
Now it seems to be working fine in offline mode (I can see map of nearest airport to my gps position) .
As soon as possible I'll check connection to the sim and checklist functionality.

Posted on January 3, 2018 22:39 by Tinamus

Hi Joao, i tried but nothing new about connection.
Airfmc is working fine but no connection on airefb.

On log file file i see this one : Loaded: S:\X-Plane 11.10/Resources/plugins/HaversineAir/64/win.xpl (com.haversine.air.xpl).

i can send you if you writ to my mail (a.bettica@gmail.com)

The only thing that i can say to add information is that when i start airfmc i need always to call sim by menù of airfmc by using voice CALL SIM and after click on connect button, it's not automaic, but this is from the beginning.

Posted on January 4, 2018 11:44 by haversine

Ahh that explains it! Your AUTO mode (multicast) is not working.

AirEFB doesn't have a CALL mode though.

OK so you need to this:

1) Download / install version 4.7.1 of the plugin (upgrade to 4.7) which fixes an issue related to manual configuration and AirEFB
2) Go to the iPad WiFi settings and note down the IP address of the iPad
3) Enter that IP address in the plugin settings in X-Plane instead of the word AUTO

that should fix it and should make X-Plane appear as a data source in the settings page of AirEFB.

hope this helps,

Posted on January 4, 2018 22:31 by Tinamus



Posted on November 5, 2018 02:13 by Gurinder

For some reason, SSG 747-800 checklist does not appear under checklists. I have verified that clist.txt exists in the SSG Boeing 747-800 folder. I installed the Haversine plugin just few days ago. I run the latest version X Plane 11 with Mojave OS. I do see the Zibo Mod B737-800X and Toliss 319 checklists.
Gurinder Grewal

Posted on November 5, 2018 11:04 by haversine

Hello Gurinder,

Must be some naming issue. Is the file named clist.txt and is on the 747 folder?

Could you send me the file by email to support so I can try it and see if there's a problem with the file?

Alternatively, you can also create a folder named: CHECKLISTS

and populate it with check list files in the form: SOMETHING.clist

Then drag and drop the entire CHECKLISTS folder to AirEFB using iTunes and its App File Sharing.

hope this helps,
joao @ haversine

Posted on November 6, 2018 16:19 by haversine

For future reference, and as detailed by email regarding the SSG 747-800 checklist problem:

1) When renaming fils to .clist if using macOS, make sure that the file really ends in .clist

Sometimes macOS finder pretends to rename files while keeping .txt hidden from the user. Click on CTRL-I to make sure the extension is really .clist and not txt

2) The clist.txt file in question was being marked as charset=unknown-8bit while AirEFB's function to open it assumed UTF8 and was failing to decode it properly. The next version of AirEFB will fix this but it it occurs, one solution is to create a new text file under macOS and copy-paste the checklist's contents to it, saving it and thus forcing UTF8.

fun flights,
joao @ haversine

Note: You need to be logged in to post in the forums.

© 2024 Haversine