Your IP address is:

Haversine Forums -> AirPlugin - The Haversine Air X-Plane Plugin

GLIBC not found error with 64 bit v3.5 plugin on Linux Mint 15 Olivia

Posted on August 13, 2013 23:28 by emelar

I've not been able to get the 64-bit version of the plugin to work under X-Plane 10.22. ldd reports library errors:

$ ldd AirTrackXPL-3.5-Lin-64.xpl
./AirTrackXPL-3.5-Lin-64.xpl: /lib/x86_64-linux-gnu/ version `GLIBC_2.0' not found (required by ./AirTrackXPL-3.5-Lin-64.xpl) => (0x00007fff36fc6000) => /lib/x86_64-linux-gnu/ (0x00007f53f2e77000) => /lib/x86_64-linux-gnu/ (0x00007f53f2aaf000)
/lib64/ (0x00007f53f32c8000)
$ ldd AirTrackXPL-3.5-Lin-32.xpl => (0xf7760000) => /lib/i386-linux-gnu/ (0xf7709000) => /lib/i386-linux-gnu/ (0xf7556000)
/lib/ (0xf7761000)

This appears to be because the 64 bit version of doesn't have GLIBC 2.0 support.

$ strings /lib/i386-linux-gnu/ | grep GLIBC
$ strings /lib/x86_64-linux-gnu/ | grep GLIBC

I'm running ok with the 3.3 version of the plugin (which ldd reports as being statically linked). Anything you can suggest would be appreciated.


Posted on August 15, 2013 10:05 by skyfox


Sorry for the delay.

Seems different Linux systems may have different libc versions. The best way is probably to build it locally.
If you're OK compiling, I can send you the source code of the plugin and you can build it in your system.

I'll send it by email,
joao @ airtrack

Posted on August 17, 2013 08:10 by emelar

Thanks very much Joao, that worked great.

Posted on July 2, 2014 15:48 by skipjv

I also have this problem "version `GLIBC_2.0' not found", with ubuntu 14.04.
I'd appreciate the source code too
many thanks

Posted on July 3, 2014 16:03 by skipjv

Ihave just tested the HSAirXPL-4.2.3 plugin on 32-bit x-plane(linux) with success.
Unfortunately, on the 64-bit plugin I still get the "version `GLIBC_2.0' not found" as above.
The libgcc1:i386 and libgcc1 both have the same installed version 1:4.9-20140406-1ubuntu1.

Posted on July 13, 2014 17:01 by skyfox


Sorry for the delay. Sent you the plugin, hopefully it will have worked.

fun flights,

Posted on October 17, 2014 17:56 by cricri9be

I have this problem with the new update HSAirXPL-Lin-64.xpl. Xplane 10.30 /Ubuntu 64 bit 14.04 and AirTrak on the Ipad.

ldd HSAIRXPL-Lin-64.xpl./HSAIRXPL-Lin-64.xpl: /lib/x86_64-linux-gnu/ version `GLIBC_2.0' not found (required by ./HSAIRXPL-Lin-64.xpl) => (0x00007fffa3537000) => /lib/x86_64-linux-gnu/ (0x00007fa3c7ea6000) => /lib/x86_64-linux-gnu/ (0x00007fa3c7ae0000)
/lib64/ (0x00007fa3c8303000)

can you give me a solution.

Hi Joao,

Please send me the latest source code to compile on Ubuntu 14.04. I'm a bit out of date.

Many thanks

Posted on October 18, 2014 16:12 by skyfox


Are you able to compile and tweak with a Makefile in order to build a few .c source files? If so I can send you the plugin source in order for you to compile it locally. Let me know if you can,

kind regards,

Posted on October 19, 2014 14:50 by cricri9be

Hi Joao,

I never compiled, if you give me the procedure step by step, I will try.


Up, no reponse.

Posted on October 20, 2014 10:17 by skipjv

Hi Joao,

Please send me the latest source code to compile on Ubuntu 14.04. I'm a bit out of date.

Many thanks

Posted on November 24, 2014 00:13 by rgham52

Hello, I am having the same problem on Linux mint 17 64bit. It works fine on 32 bit. I do not know how to compile, but could probably figure it out. If anyone else has gotten it to work, please let me know. Thanx!!


Posted on November 24, 2014 22:52 by skyfox

Hello all,

My apologies for the extreme delay; haven't had much free time recently and had to cleanup the source from confusing obsolete stuff which I just did, so sorry about it. Finally here it is:

You can download the source code from:

Please note it is work in progress and haven't had the time to prepare any documentation to go with it. The idea is to support all future apps and features with a single plugin.

With luck you might be able to compile the two versions (32 and 64 bits) with just the commands:

make lin32
make lin64

If not you may need to tweak a bit, it is basically just compiling two files, HSMPNET.c and HSAIRXPL.c and then linking them. The Makefile provided is used to originally cross compile the plugin for all platforms on OS X.

any troubles or success stories let us know,
good luck,

Posted on November 25, 2014 10:56 by cricri9be

Hi Joao,
thank you very much, it works again.

Posted on November 26, 2014 00:40 by rgham52

Got it working. This was the last hurdle to the 2 year project of designing and building a home cockpit and to have it all on linux. I use Airtrack for the FMS mainly, but it is an integral part of most every flight. Thanks for a great App!

Posted on May 20, 2015 18:37 by Piepmann

Hello all,
i am too stupid to compile the files. Sorry...Linux Newbie and never before i had to compile...
Is it possible, that anyone could send me the file for 64Bit Linux at
Thank you very much...

Posted on February 20, 2018 16:35 by skyfox

Quick update on here, this is an old thread but, any Linux people out there having problems still, just to let everyone know the plugin is now publicly available at:

Feel free to try and compile it and/or submit suggestions if you have any.

fun flights,
joao @ haversine

Note: You need to be logged in to post in the forums.

© 2022 Haversine Ltd